logo

Keyboard Shortcuts and Viewer Modes

Rotate geometry by moving mouse inside viewer window and drag while left mouse button is pressed. Usually, rotation is the default mode in the viewer.

Press right mouse button to select major interaction mode from popup menu, or use keyboard keys to temporarily switch between different modes (just keep a button pressed to switch mode temporarily):

Transformation

o Rotate surface (initial mode for perspective camera) similar to a space ball. Orbit mode.
v Rotate surface with fixed Vertical axis.
s Scale surface, drag in vertical direction.
t Translate surface in xy-plane (initial mode for orthogonal cameras).
z Translate surface in z-direction
c Center camera on object (object is centered and not scaled).
f Focus camera on object (object is centered and scaled).
x Drag a rectangle to be eXpanded to fill display. Or pick a new center without expanding.
r Reset camera and viewer, geometry returns to default position.
Left Mouse Depending on the mode, drag, pick and select the geometry in the viewer.
Middle Mouse Drag to translate geometry.
Right Mouse Drag to scale scene, or click to show popup menu to select major modes.

Animation

w Start camera auto-rotation (auto-rotation repeats the last o,s,t-action).
q Stop camera auto-rotation.
Ctrl-a Show Animation panel to steer animations
Ctrl-k Create animation by storing current geometry as keyframe.

Modeling

a Add additional vertex to geometry. New vertices will become invisible unless showing of vertices is enabled.
e Add element or polygon by picking existing or new vertices.
d Duplicate all visible geometries of a scene by reflection at a point, a line, or a plane. The point, line or plane must previously been determined by marking one, two, or three vertices of the current geometry.
i Initial pick, e.g. used drag initial points on surfaces by several applets.
m Drag a rectangle to Mark all enclosed vertices.
n Drag a rectangle to mark all touched elements.
p Pick a vertex and drag it. To see picked vertex enable display of
vertices in menu Inspector->Object->Material of control panel,
picked vertices are magenta).
u Drag a rectangle to Unmark all enclosed vertices.
Shift-u Drag a rectangle to Unmark all enclosed elements.

Rendering

Shift-a Toggle display of edge aura around edge in line drawing mode.
Shift-b Toggle display of bounding box around current geometry.
Shift-c Toggle display of center of geometry (pending).
Shift-d Toggle usage of depthcueing to fade off far away items.
Shift-f Toggle display of small coordinate frame.
Shift-g Toggle display of xy-grid.
Shift-h Toggle display of information at mouse tip.
Shift-i Toggle display of background image.
Shift-j Toggle usage of lights.
Shift-l Toggle display of border around display.
Shift-m Toggle magnet mode of vertices, i.e. highlight if nearby vertices.
Shift-o Direct select mode, geometries are automatically selected when picked.
Shift-p Toggle usage of painters algorithm. Since v4.0 z-buffer is default mode.
Shift-q Toggle display of display title information.
Shift-r Toggle display of copyright information.
Shift-s Toggle anti-aliased rendering.
Shift-t Toggle tag mode to move all marked vertices.
Shift-v Toggle fast z-buffer mode (requires z-buffer mode).
Shift-x Toggle display of coordinate axes.
Shift-y Toggle accelerated but less accurate z-buffer mode.
Shift-z Toggle z-buffer mode. Since v4.0 z-buffer is default mode.

Selecting

Ctrl-left mouse Pick geometry with left mouse while holding <ctrl> key to select geometry in display.
Ctrl-tab Select previous geometry by cycling through the set of visible geometries of the display.
Ctrl-shift-tab Select previous geometry by cycling through the set of visible geometries of the display.

Deleting

Ctrl-Shift-y Clear JavaView, remove all geometries and reset display.
Del-left mouse Keep <backspace> or <del> key pressed and pick a geometry to delete geometry from display.

Panels

F1 Show help resp. shortcut information.
F2 Close control window.
Ctrl-a or F4 Show Animation panel to steer animations.
Ctrl-b Show Label inspector.
Ctrl-d Info panel of Display inspector.
Ctrl-e Show Vector field inspector.
Ctrl-f Show Configuration inspector if geometry depends on parameters.
Ctrl-g Inspect ggraphics at Camera inspector.
Ctrl-h or F3 Show console window with Debug information.
Ctrl-i Show Info panel of current geometry if available.
Ctrl-p Show info panel of current Pjroject if available.
Ctrl-l Show Light panel of current display.
Ctrl-m Show Material panel of current geometry if available.
Ctrl-t Show Texture panel of geometry if available.

Import and Export

Ctrl-n New geometry dialog.
Ctrl-Shift-n Load a JVD file with same name as recently loaded model file.
Ctrl-o Open file import dialog.
Ctrl-Shift-o Same as Ctrl-o, but additionally load a JVD file with same name if available.
Ctrl-s Save geometry export dialog.

Emergency Exit of JavaView (application only)

Ctrl-Shift-x Exit JavaView immediately, no exit box.
© 1997-2017 Last modified: 22.06.2017 --- www.javaview.de --- The JavaView Project